Back to overview
Downtime

Dashboard experiencing issues

May 30 at 06:08am BST
Affected services
Web Dashboard
Application Backend

Resolved
May 30 at 06:46am BST

We are confident services are all running correctly and now consider the incident closed. We apologise again for any disruption caused.

Updated
May 30 at 06:25am BST

Services are back online. We are monitoring to ensure they remain stable.

Updated
May 30 at 06:20am BST

We have identified the root cause of the issue and we are working on a resolution. A further update will be provided within the next 10-15 minutes.

Created
May 30 at 06:08am BST

The Tech Log Dashboard is currently experiencing issues. The iPad app is functioning correctly although is unable to sync. We are investigating and apologise for any inconvenience. A further update will be provided shortly.