Back to overview
Downtime

Dashboard is experiencing issues

Aug 26 at 08:02am BST
Affected services
Web Dashboard

Resolved
Aug 26 at 10:19am BST

We have resolved the issue that caused Dashboard to be unavailable for some customers, and will put measures in place to prevent it from occurring again. Thank you for your patience.

Created
Aug 26 at 08:02am BST

The TechLog Dashboard is experiencing issues, but this does not impact the iPad application, and so dispatching aircraft is unaffected. We are investigating and will provide an update as soon as possible.