Tech Log degraded performance
Resolved
Jun 17 at 12:20pm BST
Load times are currently stable though we are continuing to monitor before concluding that the issue is resolved.
Affected services
Updated
Jun 17 at 11:54am BST
Load times have improved a bit but are still slow. We are continuing to investigate.
Affected services
Updated
Jun 17 at 11:20am BST
We are continuing to investigate this issue. We apologise for the disruption.
Affected services
Created
Jun 17 at 10:25am BST
We are experiencing high load times leading to Dashboard pages being barely usable and difficulties logging into the Tech Log app. We are investigating and will provide further updates as soon as we know more.
Affected services